Main Program Window

VisualApplets offers a graphical user interface for applet design. No scripting, no programming code is required to be edited. The user interface is very simple and especially designed for easy learning by users. No technical background in programming is required.

The VisualApplets main program window consists of several bars and panels:

Main Program Window

Figure 12. Main Program Window


The main menu bar provides direct access to the program features. Different toolbars can be used for quick access to important functions.

Three panels provide different information and possibilities:

  • Design panel: The design panel shows your VisualApplets project. You always have one main design window, but, depending on the structure of your project, you may additionally work with several sub windows. In the Window menu, multiple views can be selected (Tile, Cascade, Tabbed View). Using the menu entries you find in Window Diagram Windows ( Ctrl+F8 ), you can easily select the design diagram window you want to work on at the moment.

  • Information panel: In default setting of the main program window, the information panel is always displayed. It offers different information windows in tabbed view:

    • Project Info

    • Module Info

    • DRC Log

    • Build Log

    • Help

    (For details on each information window, see below.)

  • Library panel: In default setting of the main program window, the library panel is always displayed. It offers three library windows in tabbed view:

    • Operator Library: The Operator Library is a collection of sublibraries that contain VisualApplets operators, i.e. the individual image processing functions.

    • User Library: The User Library can include custom libraries with user-defined combinations of operators (hierarchical boxes). For more information see 'User Libraries'.

    • Custom Library: Into the Custom Library, operators provided by a user of VisualApplets Expert can be imported.

[Tip] Specific Operators

Some operators displayed in the operator library may not be available for the platform you are currently designing for. If not available for the platform you selected, the operator is grayed-out.

Operator not available for currently selected targed hardware platform

Figure 13. Operator not available for currently selected targed hardware platform


The Windows of the Information Panel

Project Info

The Project Info window summarizes information on the current project.

Project Info

Figure 14. Project Info


The following information is provided:

  • Name: Name of project (=filename)
  • Creation Date: Date of creation
  • Last Modified: Date of last modification
  • Version: Version number of the project; this entry can be edited from the DesignProject Details menu (see 'Project Properties')
  • Description: Verbal description of the project; this entry can be edited from the DesignProject Details menu (see 'Project Properties')
  • Type: Displays the FPGA type currently used on the target hardware (see 'Target Hardware Porting')
  • Target Runtime: Displays the target runtime (see 'Target Runtime')
  • Design Rules Check Level 1: Indicates found errors or successful performance (see 'Design Rules Check')
  • Hardware Applet: Indicates the existence of a hardware applet. The entry is checked if VisualApplets previously generated a HAP file of the project.
  • Resources: Shows the results of the resource estimation (VisualApplets Expert feature; see also 'FPGA Resource Estimation').
  • System: Displays the found XILINX version, the available runtime version, and the runtime directory. This information is used by VisualApplets to build a HAP and for the final HAP output. See 'Build' for more information.

Module Info

The Module Info window shows a list of all modules used in the project (as long als the input field of the window is empty). The list is structured by the hierarchy of the project.

Module Search

Figure 15. Module Search


In the Module Info window, you can easily search for a certain module or module type. This is very helpful when working in large designs. Before you start your search, you should define the filter settings:

  • If you want to search for the individual name you gave to the module, activate "Names".

  • If you want to search for the module type (the name of the operator the instance of which you are currently searching for), activate "Types".

Module Search

Figure 16. Module Search


You can now enter your search string. It is sufficient to enter only part of a name. A click on one of the modules listed in the Module Info window will bring the respective design window into focus (in the design panel), with the module selected and highlighted.

DRC Log

The DRC Log window displays the results of the last Design Rules Check. A click on one of the module names listed under a warning/error message will bring the respective design window into focus (in the design panel), with the module selected and highlighted.

DRC Log Information

Figure 17. DRC Log Information


Build Log

The Build Log window displays the results of the last Build.

Build Log Information

Figure 18. Build Log Information


Help

The Help window offers context-sensitive help on individual operators.

To open the context-sensitive help you can either:

  1. Select the operator you want information on directly in you design and press F1 to open and display the corresponding information in the Help window.

  2. Select a operator from the Operator Library window. The Help window will always show the help for the current selection.

Example: Displaying Information on the CONST Operator

Figure 19. Example: Displaying Information on the CONST Operator


If you press F1 in any other window or click on a help button, the context sensitive user manual help for the current selected window or function will open. Of course, you can access the operator help directly form this user documentation, too. See Operator Reference.

The Windows of the Library Panel

The library panel displays the Operator Library window, the User Library window and the Custom Library window in tabbed view.

All libraries (Operator Library, User Library, and Custom Library with all their sublibraries) are organized in a tree structure. Each library contains operators.

The visualization of the structure can be changed by selecting either "Tree", "List", or "Icon" view.

Library Panel with Operator Library on Display

Figure 20. Library Panel with Operator Library on Display


In the search field, a search string can be entered to filter the list for only the required operators. Camera for example will list all operators containing camera in their name.

Operator Library

The Operator Library is a collection of sublibraries that contain VisualApplets operators, i.e. the individual image processing functions.

You can get detailed information on each operator by clicking on the operator name in the Operator Library window and clicking on the Help tab in the information panel.

Libary Panel with Operator Library on Display

Figure 21. Libary Panel with Operator Library on Display


See 'Inserting Operators' on how to add new operators to a diagram. A detailed documentation of all operators is given in Operator Reference.

User Library

The User Library can include custom libraries with user-defined combinations of operators (hierarchical boxes). For more information see 'User Libraries'.

Custom Library

Into the Custom Library, operators provided by a user of VisualApplets Expert can be imported.

Adapting the Main Program Window

You have various options to adapt the main program window of VisualApplets to your personal preferences:

Adapting Toolbars

Toolbars can be rearranged by drag and drop or added/removed by a right click.

Restoring the Default Setting of the Main Program Window

If you accidentally arranged the windows or toolbars in a way you didn't want to, you can restore the default setting by WindowReset Dock Windows ( Ctrl+O ) or by clicking the corresponding icon in the View toolbar.

Number of Files under File -> Recent Designs

Under FileRecent Designs VisualApplets offers you a list of recently opened VisualApplets files (*.va). You can configure the actual number of files displayed.

To define how many recently opened files are displayed:

  1. Go to menu SettingsSystem settings and select category Common.

  2. Under Recent designs, define the number of files you want to have displayed (up to 24).

  3. Confirm with Ok.

Configuring the number of displayed recent designs

Figure 22. Configuring the number of displayed recent designs