Simulation

VisualApplets provides powerful, functional simulation features for simulating designs. You can use simulation for a first test of the implemented image processing algorithm, and for its verification. You can start a simulation directly after editing the design without the need to build a *.hap file.

The simulation in VisualApplets is functional, i.e., it emulates the behavior of the hardware implementation. This makes it very fast compared to low level simulations. A side effect of the functional simulation is that timing is not considered. Silicon Software guarantees that the simulation behavior of operators is 100% equal to the behavior of the final applet on real hardware.

Exception: A few operators are non-deterministic and therefore, will in simulation not return the same result output order as on hardware (currently, only Blob Analysis operator and PseudoRandomNumberGen). These exceptions are described in the corresponding operator documentations (see Operator Reference).

To simulate the behavior of a design in VisualApplets, you need to insert two kinds of simulation elements into your design:

  • image sources, and

  • simulation probes.

Image sources are used for simulation input. You can load one image or a whole image sequence into a simulation source (from image files). You can place an image source at any position in your design.

Simulation probes are used to monitor the results of the image processing simulation. You can place a simulation probe at any position in your design. The results of the simulation you can save to image files.

Due to visualization optimizations, the VisualApplets simulation is based on 2D images.

Nevertheless, you can also simulate if the link the simulation source is connected to is 1D or 2D, as long as the source contains 2D images (see 'Image Protocols, Image Dimensions and Data Structure').

[Important] Important

Simulation of the SIGNAL image protocols is not possible since VisualApplets design simulation emulates the functionality, but not the timing of a design (which would be necessary to simulate SIGNAL image protocols).

Simulation Workflow

Simulating image data processing in your design comprises the following steps:

  • Inserting the simulation sources and probes you need into your design.

  • Loading the image file(s) you want to use for simulation to your simulation source(s).

  • Setting several parameters (like pixel merge and pixel alignment) to optimize your image input.

  • Setting the parameters for the actual simulation in the main simulation window.

  • Starting the simulation.

  • Evaluating the simulation results.

  • Saving the simulation results.

In the following sections, these steps will be described in full detail.

Inserting Sources and Probes

The first step you have to take when preparing a simulation is to insert your simulation source(s) and probe(s) into your design.

  1. From the main menu, select Analysis (or use the corresponding icons in the toolbar) to insert your source(s) and probe(s) into the current design window.

Analysis Menu

Figure 65. Analysis Menu


Simulation sources and simulation probes are both displayed as small image frames with a magnetic anchor:

Figure 66.


The anchor is used to connect the source/probe to a link in the design. Simulation sources can be easily distinguished from simulation probes as sources are of gray, probes of green color.

  1. Use drag and drop to position your source(s) and probe(s).

  2. Use drag and drop to connect your source(s) and probe(s) to links in your design. If the anchor icon changes to blue, the connection is valid.

[Caution] Caution

A simulation source cannot be connected to a link that transports kernels.

Simulation Source

The Simulation Source Viewer

In the simulation source viewer, you can load test images or test image sequences and make them available for simulation.

At first, let’s have a quick look at the Viewer. (A detailed description of all its options and functions you will find in the subsections that follow.)

  1. Double click on a source in your design to open the source viewer.

The Source Viewer window opens:

Source Viewer Window

Figure 67. Source Viewer Window


Directly under the menu, you find the toolbars. The icons of the toolbars offer the following options (left to right):

  • File toolbar for opening and saving image files.

  • View toolbar offering different options for image display. These are the same as the first options of the View menu:

    Viewing Options

    Figure 68. Viewing Options


  • The arrows for navigating through image sequences.

  • Display of details on the image currently visible in the display panel of the main viewer window (and magnifier): Position of image in image sequence loaded to the simulator, and path to image file

On the left hand side, you have the settings panel with two tabs:

Image File – Mapping Here, you can optimize the settings for simulation, e.g. enter a value for pixel merge, or define the offset for pixel alignment

Display Properties Here, you can define the settings for displaying the test images on your own screen (due to the fact, that monitors always use 8 bit color display, at times you have to decide which part of a pixel you want to see on screen for evaluating your test images). None of the settings you define under Display Properties have influence on the actual simulation or its results.

In addition, you find here the actual color values of a selected pixel listed, together with the display value (the display value is the mapped value for display on the user monitor).

Pixel Values

Figure 69. Pixel Values


On the right hand side, you have the display panel displaying the image currently selected.

You can zoom in and out on the image displayed in the display channel by either using the corresponding icons in the toolbar, or by using CTRL+MouseWheelUp to zoom in und CTRL+MouseWheelDown to zoom out.

If you choose a very high zooming factor, a pixel grid is displayed for better orientation.

On the bottom of the simulation viewer, you have another panel: This is the Sequence viewer. If you use more than one image in a source, here you can see all images of the image sequence, make changes to the image order of the sequence, or select an image for display in the display panel and magnifier.

The Magnifier is actually a second window of the Source Viewer which you can easily loosen from the main Source Viewer window via drag & drop. The Magnifier always shows the same image as is displayed in the display panel of the main Source Viewer. Its pointer is always in the center of the magnifier window and positioned exactly on the pixel you point at in the display panel. The great advantage of the magnifier window is that you can display a selection of the image with a completely different zooming factor:

Zooming in the Magnifier

Figure 70. Zooming in the Magnifier


If you want to change the zooming factor of the Magnifier:

  1. Activate the Magnifier window.

  2. Use CTRL+MouseWheelUp to zoom in und CTRL+MouseWheelDown to zoom out.

If you choose a very high zooming factor, a pixel grid is displayed for better orientation.

Loading Images into the Source

To load test images or test image sequences into your source,

  1. Open the simulation source viewer by double clicking on the source in your design.

  2. From the main menu of the viewer, choose File -> Open (or click on the corresponding icon in the toolbar). In the following dialog, select the simulation input image file and click on Open.

[Note] Note

You find some useful test images in the VisualApplets installation folder (under \Testimages).

[Tip] Tip

Alternatively, you can simply drag & drop image files (either from your Windows Explorer into the viewer, or from your Windows Explorer onto the source in your diagram).

The input image should now be displayed in the simulation source viewer.

After closing the Viewer, you see a thumbnail of the image in the preview frame of the corresponding source:

Thumbnail Display in Source

Figure 71. Thumbnail Display in Source


As soon as you connect a source to a link, the source takes over the parameter settings of the link (such as maximal image dimension, bit width, and color format). If you load an image that is bigger than the maximal image dimension of the link, a green rectangle is displayed on the image, enclosing the part of the image that will be used for simulation:

Highligted Image Section Used for Simulation

Figure 72. Highligted Image Section Used for Simulation


[Caution] Convert Your Images

It is not possible to load a color picture on a one-channel gray link and vice versa. If your test image does not fit the properties of the link the source is connected to, you need to convert the image. Use any image processing program that offers the necessary functions to convert your test image. Use an image format supported by VisualApplets. For information on supported image formats, see 'Supported Image File Formats'.

Image Sequence

As soon as you load a new image to the source, the image shows up in the display panel of the source viewer and is added to the image sequence of your source. You can see all images of your image sequence in the Sequence Viewer (located at the bottom of the Simulation Source Viewer).

Only the selected image displayed in the display channel is stored in the RAM of the computer. The other images of the sequence are loaded into the RAM when necessary. Thus, loading long image sequences onto a source has nearly no impact on RAM usage.

If you load an image sequence, you can change the order of images after load. In the Sequence Viewer, use drag & drop to position an image to where you want it to be in the sequence.

You can easily delete one or more images of a sequence:

  1. Press CTRL and select the images you want to delete.

  2. Press DEL or select from the menu EditRemove Selected.

"sim[x]" indicates the image that is being simulated during the next simulation step. You can reset "sim[x]" to the first image of the sequence in the Simulation dialog by clicking the Reset button. (If you want to know more about simulation steps and reset, see 'Starting a Simulation'.) The simulation order is not influenced by the image currently displayed in the display panel.

If you change the image properties by mapping (see 'Image File Mapping '), the thumbnails are not refreshed automatically. By default, the Sequence Viewer displays the thumbnails of the original images.

You have two possibilities to adapt the thumbnail display. From the menu, select either

  • ViewMapped Thumbs to get a preview on how your images will look after applying the current mapping settings in a simulation, or

  • ViewRefresh to have thumbnails displayed that reflect the current look of your images.

Pixel Values

On each pixel in the display panel, actually two crosshair cursors are displayed (If you can’t see the two crosshair cursors, just zoom in on the picture in the display panel):

Crosshair Cursors in Display Window and Magnifier

Figure 73. Crosshair Cursors in Display Window and Magnifier


The white/black crosshair cursor shows the actual position of the cursor of your mouse.

The colored one is positioned in the center of the pixel the mouse cursor points on. This crosshair cursor is also displayed in the Magnifier on exactly the same pixel.

In the settings panel, tab Display Properties, the corresponding pixel values are displayed:

Pixel Values

Figure 74. Pixel Values


You can choose if you want to see them as decimal unsigned, decimal signed or hex figures.

Under Display, you get the value(s) displayed on your screen. This value/these values might be different from the actual color values (or gray value) if a 16 bit or 48 bit image is loaded to your source, since on screen, only 8 bit can be displayed per color channel.

Image Dimension

In the settings panel, tab Image File – Mapping you find a table with the image dimensions of the actual image (as it is loaded in from file) on the left hand side and the image dimensions of the link on the right hand side:

Image Dimensions

Figure 75. Image Dimensions


(The column Merged Pixels will be described below.)

If an image file has a dimension smaller than the dimension of the link, the image will be transferred onto the link on the scale 1:1.

If the image file has a dimension that exceeds the dimension of the link, only part of the picture will be used for simulation. Which part is going to be used you can see in the display panel (green rectangle). Also, the corresponding values are highlighted in yellow:

Exceeded Image Dimensions

Figure 76. Exceeded Image Dimensions


[Tip] Tip

If you cannot see the green rectangle in your display screen, set your viewing options to Fit to Window (menu ViewFit to Window).

Image File Mapping

The same table (settings panel, tab Image File – Mapping) gives information on the bit width of your test image (file) and on the bit width of the link the source is connected to:

Bit Widths of Image and Link

Figure 77. Bit Widths of Image and Link


(The column Merged Pixel will be described below.)

If you want to load an image that has a bit width higher than that of the link, you can choose which bits of your image you want to use for simulation. You do so in the settings panel, tab Image File – Mapping. You can make your selection by using a slider:

Defining Offset for Image Bits to Use

Figure 78. Defining Offset for Image Bits to Use


The bit width of the selection slider is the same as the bit width of the link. What you can do with the slider is to define a new position for the offset. (The offset is the starting point of your bit selection on the bit width of your image). Based on these settings, the Source Viewer immediately calculates the altered image and displays it in the display panel. In the screen shot above, the 4 upper bits have been chosen out of the 8 bit of the 8-bit image. Thus, the test image used for the simulation will only have 16 instead of 256 gray-scale values.

[Note] Visualization of Altered Test Image in the Source Viewer

Since the display on PC monitors is based on 8-bit information per pixel, an image with only 16 gray-scale values cannot be displayed properly. Thus, for visualization on screen the 16 gray-scale values of the test image are mapped to the 256 gray-scale values of the 8-bit monitor display. This mapping doesn’t change the number of shades of gray displayed (16), but enhances the contrast between them ( 0 = black, 15 = white).

Display Properties for 4-bit Image

Figure 79. Display Properties for 4-bit Image


If you, on the contrary, load an image that has a smaller bit width than the link it is loaded on (the source module is connected to), you can use the very same slider (in the settings panel, tab Image File – Mapping) to define an offset for the bits of the image on the bit width of the link. The remaining bits of the link are set to NULL.

The picture below shows an example where an 8-bit grayscale image has been loaded onto a link with a bit width of 12 bit:

Defining Offset for Link Bits to Use

Figure 80. Defining Offset for Link Bits to Use


Display Alignment

You can define some settings for vizualizing the altered test image in the Source Viewer via display alignment:

If the bit width of a link is higher than 8 bit, you have to define which 8 bits out of the link bit width you want to have displayed in the display panel. (Since the display on PC monitors is limited to 8 bit per color channel, a higher bit width cannot be displayed.)

In the settings panel, tab Display properties, you can define which 8 bits out of the bits of a link you want to have displayed in the display panel. Use the slider to choose the offset for the displayable 8 bits. "resources/user-manual/design-settings" This display alignment setting has no influence on the simulation.

In the example below, the link has a bit width of 12 bit. With the slider, you can decide which bits out of the 12 you want to have displayed.

Display Alignment

Figure 81. Display Alignment


Pixel Spitting and Merging

The BMP file format allows a maximum of 8 bit per color channel of a pixel. The Tiff format allows a maximum of 16 bit per color channel. A higher bit width cannot be simply saved in standard image file formats.

VisualApplets offers the possibility of pixel splitting to get around these limitations.

To store an image with a high pixel bit width in a standard image file format, each pixel is split into multiple image file pixels. Thus, it is possible to store up to 64 bit per color channel in BMP or TIFF file format, e.g., in 8 x 8-bit pixels. These images can be viewed in regular image file viewers or image processing programs. Of course, the VisualApplets generated pixel-split-images will be displayed horizontally expanded. Thus, in VisualApplets, pixel splitting is a mere storing option for images with a high bit width (color depth).

To load an image with high bit width that has been stored as a BMP or TIFF file into your simulation source, you have to merge the adjacent pixels that share the color information for one original pixel back to one pixel. Thus, simulation source viewers can merge the pixel-split-images for correct mapping. The splitting can be done in simulation probe viewers (see 'Simulation Probe'). You can define the settings for pixel merge in the settings panel, tab Image File – Mapping:

Pixel Merge

Figure 82. Pixel Merge


In the following example, a 2048x1024 BMP file with a bit width (color depth) of 8 bit has been loaded into the source. It is to be interpreted as a 16 bit 1024x1024 image.

If you enter 2 in the “Merge N pixel into 1 pixel“ field, the bit width of the image in your source changes from 8 bit to 16 bit per color channel, whereas the row length of the image in your source will be only half as long, thus changing from 2048 to 1024 pixel.

Before merge:

Merging Factor = 1, Image Properties Do Not Fit Link Properties

Figure 83. Merging Factor = 1, Image Properties Do Not Fit Link Properties


After merge:

Merging Factor = 2, Properties of Merged Image Fit Link Properties

Figure 84. Merging Factor = 2, Properties of Merged Image Fit Link Properties


Starting a Simulation

After you have loaded a test image or test image sequence to your source and defined all settings for the image, you can start with the actual simulation.

[Caution] Use Simulation Probes

Make sure you inserted (and connected) simulation probes on all positions where you want to check image processing results (see ' Inserting Sources and Probes ').

  1. From the main menu, select AnalysisStart Simulation, or click on toolbar icon Start Simulation. Now, VisualApplets automatically triggers a Design Rules Check 1.

    The main simulation window opens:

    Main Simulation Window

    Figure 85. Main Simulation Window


    In the upper pane, all simulation sources and simulation probes currently active in the design are listed. The list serves only information purposes.

    In the lower pane of the window, you see the results of Design Rules Check 1.

    You can change the display of the list:

    • Simulation Sources and Simulation Probes display only the sources and probes you have set for simulation.

    • All Sources and All Probes display all data sources and data destinations within your design.

    Changing Source and Probe Display

    Figure 86. Changing Source and Probe Display


[Caution] Influence of Errors and cautions

A simulation can only be started if no error was detected during Design Rules Check 1. Warnings created by Design Rules Check 1 do not prevent starting the simulation.

[Note] Note

Single operators cannot be selected for simulation. A simulation will always run through all operators of a design.

If the list in the main simulation window shows a simulation source or probe marked by a yellow Warning triangle, this source/probe is not connected to a link of your design and will be ignored during simulation.

Non-connected Simulation Modules

Figure 87. Non-connected Simulation Modules


In the Processing Cycle field, you can specify how many processing cycles you want the program to carry out. In one cycle, on each source module of the design one image is fed in (i.e., simulated).

[Note] Processing Order of Images within a Source Module

In a new processing cycle, always the next image of the image sequence loaded to the source is processed. When all images of the sequence have been processed, the first image of the sequence is processed again.

If only one image is loaded to the source, this image is processed again and again with each processing cycle. (For example, if you specified 4 processing cycles, the one image of the source is being processed four times.)

Depending on your design, the number of images fed into the design might differ from the number of images you get as an output, for example when you use the operators SplitImage or Removemage. Thus, for one processing cycle, you might get more or less images as result(s) in a probe than you have source modules in your design. (See also example ' Multiple DMA Channel Designs ' in the VisualApplets tutorial.)

The Reset button you can use to clear the simulation and reset it to the startup condition.

A reset produces the following effects:

  • The image sequence in all simulation sources is reset, that is, a new simulation will start with the first image of the sequence again.

  • The content of all probes is deleted.

  • All operators are reset to their startup condition (e.g., image counters).

[Important] Reset before Simulation

You should always reset before starting a new simulation (as long as you are not performing a sequence simulation).

Now, you are ready to start the simulation of data processing as defineed in your design.

  1. Click on Start to start the simulation.

The current simulation status is displayed in a progress bar (at the bottom of the Simulation window). Warnings and errors are displayed in the Log panel (which you can open or close by clicking the Show Details/Hide Details button). As soon as warnings or errors occur, the Log panel is displayed automatically.

[Tip]

If you want to, you can keep the viewer windows of your simulation modules open during simulation. However, this will slow down simulation.

Successful Simulation

Figure 88. Successful Simulation


While a simulation is in progress, the simulation probe modules are filled with the resulting images. Thumbnails of the simulation results are displayed in the preview image frames. After opening the simulation viewer window of a simulation probe, the result(s) will be displayed in full size.

[Note] Automatic Simulation Reset

The simulation will automatically reset when you change your design. On reset, all simulation probes are cleared, too.

Simulation Probe

After the simulation, you will find the simulation results in the probes.

The Probe Viewer window opens. It looks pretty much like the Source Viewer window (see 'Simulation Source'): You have the settings channel at the left-hand side, the display channel on the right hand side, and the Sequence Viewer at the bottom of the Probe Viewer window.

  1. Double-click on a probe in your design to open the probe viewer.

In the Probe Viewer, you get the simulation results displayed for a first evaluation. You can alter the display options by pixel alignment, and save the images to file. For saving, there are several options available, like, e.g., pixel splitting.

You can zoom in and out on the image displayed in the display channel by either using the corresponding icons in the toolbar, or by using CTRL+MouseWheelUp to zoom in und CTRL+MouseWheelDown to zoom out.

If you choose a very high zooming factor, a pixel grid is displayed for better orientation.

Pixel Values

Like in the Source Viewer, on each pixel in the display panel two crosshair cursors are displayed (If you can’t see the two crosshair cursors, just zoom in on the picture in the display panel). The white/black crosshair cursor shows the actual position of the cursor of your mouse, whereas the colored one is positioned in the center of the pixel the mouse cursor points on. This crosshair cursor is also displayed in the Magnifier on exactly the same pixel.

In the settings panel, the corresponding pixel values are displayed:

Pixel Values Probe

Figure 89. Pixel Values Probe


You can choose if you want to see them as decimal unsigned, decimal signed or hex values.

Under Display, you get the value(s) displayed on your screen. This value/these values might be different from the actual color values (or gray-shade value) if a 16 bit or 48 bit image is in your probe, since on screen, only 8 bit can be displayed per color channel.

If the simulation probe is connected to a link which transports kernels, you can select the individual kernel images in the kernel Row and kernel Column spin boxes (under Kernel, see above).

Image Sequence

Once an image is simulated, it is instantaneously displayed in the Probe Viewer and added to the Sequence Viewer.

You cannot change the order of images in the Probe Viewer.

However, you can delete one or more images of a sequence:

  1. Press CTRL and select the images you want to delete.

  2. Press DEL or select from the menu EditRemove Selected.

If you change the image properties by mapping (for example, when you save 16-bit images in BMP files), the thumbnails are not refreshed automatically. By default, the Sequence Viewer displays the thumbnails of the original simulation results.

Varying Row Length

VisualApplets is not limited to processing and displaying rectangular images with homogeneous row length. It can also display images with rows that are of different length.

The image size for such images is calculated by VisualApplets as follows:

[Tip] Calculating Image Size for Images with Inhomogeneous Row Lengths

image size = number of pixels of longest row * number of rows

(Rows with row length NULL are counted as well.) The undefined areas of the image are represented in the display by a blue-to-cyan color gradient:

Display of Undefined Image Areas

Figure 90. Display of Undefined Image Areas


Empty images are displayed by the symbol Empty Image and cannot be saved.

"Empty Image" Symbol

Figure 91. "Empty Image" Symbol


Display Alignment

The display panel of the Probe Viewer offers two ways of display for the same image:

  • If you activate Link View, the image is displayed as it looked like when it was passed to the probe by the link.

  • If you activate File View, the image is displayed as it will look when you save it with the current settings to file.

Since monitors always use 8 bit per color channel, images with higher or lower bit width cannot be displayed without further ado.

If a simulation result has a bit width higher than 8 bit, you can use the offset slider to select the 8 bit you want to have displayed in the display panel:

Link View

Figure 92. Link View


In this example, the upper 8 bits of a 16-bit gray scale are chosen for display.

If the bit width of the image is smaller than 8 bit, the gray-scale values of the test image are automatically mapped to the 256 gray-scale values of the 8-bit monitor display. This mapping doesn’t change the number of shades of gray displayed, but enhances the contrast between them. Without this mapping, the human eye might not be able to see an image at all. Take, for example, 1-bit images: If the values 0 and 1 are used for monitor display without mapping, both are interpreted as black by the human eye. In this case, the automatic bit width mapping of VisualApplets interprets 0 as 0 (black) and 1 as 255 (white).

Saving Simulation Results

You can save your simulation results in two image file formats, Tiff and BMP. The Tiff format offers native support of 8 and 16 bit per color channel, whereas BMP offers only 8 bit per channel.

Before you actually save your image, you should define all saving settings in the Save Options dialog.

  1. To open the dialog, from the main menu select FileSave Options.

Save Options Dialog

Figure 93. Save Options Dialog


File Format

Here, you can define the format you want to save the image in (under Destination File Format):

File Format Options for Saving

Figure 94. File Format Options for Saving


If you want to save a 1-bit simulation result in an 8-bit file format, check the box Normalize gray values. “Normalizing” in this context means mapping 0 to 0 (black) and 1 to 255 (white).

Pixel Alignement

If the bit width of the image (= the bit width of the link) is the same as the bit width of the file format you have chosen for saving, you can save the image 1:1.

If the bit width of the image is smaller than the bit width of the file format, you can change the pixel alignment offset using the slider. This way, you can save the bits of the simulation result on a certain location within the (larger) pixel of the file format. (This way, you can, for example, save the bits of a 12-bit link on the lowest 12 bits or the highest 12 bits of a 16 bit TIF image.)

If the bit width of the image is larger than the bit width of the file format, you can use the slider for choosing which bits out of an image pixel you want to save to file and which bits can be discarded.

To get an preview on the (stripped) image as it will be saved to file: In the main window of the Simulation Probe Viewer, set the radio button on top of the settings panel to File View.

Pixel Splitting

If you want to use the pixel splitting option of VisualApplets, define here on how many pixels you want to split the color information of one pixel (see also 'Pixel Spitting and Merging') .

If you want to save, for example, a 16-bit simulation result in a 8-bit BPM file, set Split 1 Pixel into to 2 pixels. Now, the 16-bit pixel of the image is split into two 8-bit pixels.

Setting the Splitting Factor in the Save Options Dialog

Figure 95. Setting the Splitting Factor in the Save Options Dialog


By splitting, the row length is doubled, tripled, etc. (depending on the splitting factor). In our example, the row length is doubled. Regular image visualization/processing programs can display these split images. But since they assume a bit width of 8 bit, the image display is expanded horizontally.

[Note] Reconversion of Split Image

You can load a splitted image in a simulation source and re-convert it to its original bit width by using the pixel merge option (see 'Pixel Spitting and Merging').

Saving

[Important] Important

When selecting FileSave from the main menu, all settings you have defined in the Save Options dialog are applied.

For saving your simulation results to file, proceed as follows:

  1. Selecting from the main menu FileSave.

  2. Define saving location and file name.

  3. Click on Save.

[Tip] Saving an Image Sequence

You can also save a whole image sequence. First, you have to select all images you want to save in the Simulation Viewer. To do so, hold CTRL pressed and click on the images. Then, select from the main menu FileSave. The images will be numbered automatically.

Supported Image File Formats

Bitmap

BMP 1 bit black/white (row length has to be a multiple of 8)

BMP 8 bit gray

BMP 24 bit (R8 G8 B8) sRGB color space

Compression like RLE is not supported.

TIFF Tagged Image File Format

TIFF 1 bit black/white (row length has to be a multiple of 8)

TIFF 8 bit gray

TIFF 24 bit color sRGB color space

TIFF 48 bit color sRRB color space

Compression: None, LZW, or PackBits

Notes

BMPs and TIFFs with indexed color palette are not supported.

Frequently Asked Questions

Question 1: : I converted a color image to a gray-scale image and tried loading it to a simulation source. But VisualApplets denies loading the image onto a one-channel link. What is the problem?

Solution 1: The image still uses 3 channels (with 0% saturation) for color information. Just convert your image to a one-channel image.

Question 2: My simulation probes do not include any results after simulation.

Solution 2: You might not have simulated enough simulation cycles. Increase the number of cycles. Moreover, your algorithm might not generate any output images. Check the respective operator restrictions in the operator references.

Question 3: My simulation probes are cleared automatically.

Solution 3: Each time the design is modified, the simulation probes might get cleared. This can be a minor change of your design like moving modules.