Skip to content

System Requirements for VisualApplets 3.3.0#

PC and Operating System#

  • OS: Microsoft Windows 8.1, or Windows 10 (64bit)
  • PC Memory: Minimum 4 GByte, recommended: 8 GByte or better
  • Minimum available hard disk space: 1 GByte

Third-Party Software#

  • For compiling the SDK examples, a C++ Compiler is necessary.
  • Depending on the target platform (FPGA type) of the applets designed with VisualApplets, Xilinx Vivado (WebPACK (free) or Design Suite) or Xilinx ISE (WebPACK (free) or Design Suite). For details, see below.

The table below lists all Basler target hardware and the required Xilinx ISE and/or Vivado licenses.

Note that for building designs for mE5 marathon frame grabbers, it is strongly recommend to use Xilinx Vivado. Using Xilinx Vivado, the build process is much faster, and more complex designs can be fitted on the FPGA.

Which Xilinx Toolchain and Version for Which Frame Grabber Platform?#

Basler Frame Grabber Model microEnable (mE) WebPACK (free license) ISE Design Suite Logic Edition
(Purchase Version)
Vivado Design Suite
(Purchase Version)
Xilinx ISE 30-Day Evaluation License Version 14.7 Vivado 30-Day Evaluation License
mE IV VD1-CL ISE version 9.2 or higher Recommended version: 9.2
PixelPlant PX100,
PixelPlant PX100e
ISE version 9.2 or higher Recommended version: 9.2
mE IV VD4-CL/PoCL Recommended version: 9.2
mE IV VQ4-GE/-GPoE Recommended version: 9.2
PixelPlant PX200e Recommended version: 9.2
mE5 ironman VQ8 CXP6-D ISE version 14.7 Version 14.7 ISE 30-Day Eval,
version 14.7
mE5 ironman VD8-PoCL ISE version 14.7 Version 14.7 ISE 30-Day Eval,
version 14.7
mE5 marathon VF2 ISE version 14.7,
Vivado version 2016.1 or highera
Version 14.7 Version 2016.1 or highera
mE5 marathon VCX-QP ISE version 14.7,
Vivado version 2016.1 or highera
Version 14.7 Version 2016.1 or highera
LightBridge VCL ISE version 14.7,
Vivado version 2016.1 or highera
Version 14.7 Version 2016.1 or highera
mE5 marathon VCL ISE version 14.7,
Vivado version 2016.1 or highera b
Version 14.7 Version 2016.1 or highera
mE5 marathon VCLx ISE version 14.7 Version 2016.1 or higherb Vivado 30-Day Eval, version 2016.1 or highera

  1. Basler recommends to use Vivado 2017.4. Basler only tested until and including Vivado 2020.2 and thus recommends to use a version between 2016.1 and 2020.2.

  2. In VisualApplets 3.2.1, applets for the platforms mE5-MA-VCL and mE5-MA-VCLx cannot be built with Vivado 2020.2. For further information, see Known Issues VisualApplets Release 3.2.1, entry 28., issue n° 9848.

Back to top