Skip to content

Overview of the pylon Viewer#

The pylon Viewer is an application for viewing and changing most of the camera parameter settings using a graphical user interface.

The pylon Viewer is part of the Basler pylon Camera Software Suite. It is available for Windows, Linux, and macOS.

Main Window#

pylon Viewer Main Window

File Menu#

Use the File menu to exit the pylon Viewer and to save the current image.

View Menu#

The View menu offers the following commands:

  • Zoom In: Zooms into the image.
  • Zoom Out: Zooms out of the image.
  • Zoom to Fit: Makes the image fit into the image display area.
  • Zoom 100%: Restores the image to its original size.
  • Full Screen: Displays your image in full-screen mode.
  • Clear Message Log: Clears all messages from the Message Log pane.
  • Show/Hide Crosshair: Shows or hides a crosshair in the image display area.
  • Show/Hide Grid: Shows or hides a grid in the image display area.

Camera Menu#

The Camera menu gives you commands to operate the camera, to manipulate the camera's settings or to add a GigE camera that wasn't detected automatically:

  • Open Device: Opens a device, i.e., to make it available for use.
  • Close Device: Closes a device.
  • Single Shot: Captures a single image.
  • Continuous Shot: Lets the camera capture images continuously.
  • Stop: Stops image capturing or stops a recording.
  • Pause: Pauses a recording.
  • Record: Records a video. The recording will start with the current settings. If you want to change any settings, open the Recording Settings pane via the Window menu.
  • Save Features: Saves the current settings of the camera features in a .pfs file. The extension ".pfs" stands for "pylon feature stream".
  • Load Features: Loads a .pfs file containing previously saved settings of camera features. The extension ".pfs" stands for "pylon feature stream".
  • File Access: Provides access to the file system of the camera, e.g., for uploading or downloading user sets.
  • Copy Camera Features: Copies the current settings of all camera features to the clipboard. This allows you to use them in a different context.
  • Add Remote GigE Camera: Adds a GigE camera by entering its IP address. This is useful if you want to add a camera that is not in your network and therefore doesn't get detected automatically.
  • Automatic Image Adjustment: Performs automatic image adjustment.
  • Vignetting Correction: Removes vignetting artifacts from your image.

Tools Menu#

The Tools menu gives you access to a variety of tools as well as the Options dialog.

Tools

Options

  • General: You can customize the pylon Viewer and select whether to use the online or the offline version of the help.
  • Language: You can change the language of the pylon Viewer, the pylon IP Configurator, and the pylon USB Configurator. Available languages are Simplified Chinese, English, Japanese, and Korean.
  • Camera Emulation: You can specify the number of camera emulation devices available in the pylon Viewer.
  • Crosshair: You can modify the appearance of the crosshair.
  • Grid: You can modify the appearance of the grid.

Workbench Menu#

The Workbench menu allows you to create and save recipes for creating image processing designs.

Window Menu#

The Window menu allows you to select or deselect the panes that you want to display, e.g., the Devices pane or the Histogram pane.

Help Menu#

Use the Help menu to submit feedback on the pylon application, contact Basler support, and view general information about the pylon Viewer, e.g., version and data privacy information. You can also access the Basler Product Documentation, the pylon Deployment Guide, the pylon SDK Samples Manual, and all the programmer's guides (if SDKs have been installed) as well as an overview of [vTool Licensing] information.

Toolbar Buttons#

Icon Function
Open Device Icon Opens/closes the device currently selected.
Save Icon Saves the current image.
Single Shot Icon Captures a single image.
Continuous Shot Icon Captures images continuously.
Record Icon Starts recording with the current settings. If you want to change any settings, open the Recording Settings pane via the Window menu.
Pause Icon Pauses the recording.
Stop Icon Stops capturing images or stop a recording.
Zoom In Icon Zooms into the image.
Zoom Out Icon Zooms out of the image.
Zoom to Fit Icon Makes the image fit into the image display area.
Zoom 100% Icon Restores the image to its original size.
Full Screen Icon Displays your image in full-screen mode.
Crosshair Icon Shows/hides a crosshair in the image display area.
Grid Icon Shows/hides a grid in the image display area.
Histogram Icon Opens/closes the Histogram pane.
Sharpness Indicator Icon Opens/closes the Sharpness Indicator pane.
Automatic Image Adjustment Icon Lets the camera automatically make all settings necessary to get a good image under current conditions.
Workbench Icon Opens/closes the Workbench pane.

Panes#

The pylon Viewer provides a variety of panes for working with devices, providing information about devices and features, and creating image processing designs using the pylon Workbench. The panes that are included in the default layout of the pylon Viewer are listed below. For descriptions of Workbench-related panes, see Overview of the Workbench.

Devices Pane#

The Devices pane displays a device tree in which all cameras that are connected to your computer are listed grouped by interface type. The interfaces shown vary depending on which options you have chosen during the installation of the pylon Camera Software Suite. As an example, a Basler boost CXP-12 camera, Basler ace 2 GigE camera, a Basler pulse USB camera, a Basler ace USB camera, and a camera emulation device are shown in the screenshot above. Using the Show Cameras Only option, you can display only the cameras without the interface information.

In this pane, you can also select whether to auto-scan in regular intervals for recently connected devices. Alternatively, you can click the Refresh button (Refresh Icon) to refresh the device tree manually.

Features Pane#

The Features pane displays the features of the camera that is selected in the Devices pane. By default, it contains two tabs:

  • Features – All: This pane lists all features that are available on the camera currently selected. Here, you also have the option to group features that you need frequently or for a specific task. For instructions how to do this, see To group features below.
  • Features – Basic: This tab contains a reduced set of features that allows you to quickly set up a camera.

To group features:

  1. Click the Edit Feature Tabs button.
  2. In the Edit Feature Tabs dialog, enter a name for the new tab.
  3. Drag the desired features from the Features pane into the Edit Feature Tabs dialog.
  4. When you have finished adding features, click OK.

The new feature tab will be displayed in the pylon Viewer. You can dock it like the other tabs or leave it floating. The new tab will also be added to the Window menu.

You can use this custom tab for all camera models, i.e., you can create a tab for an ace 2 GigE camera and use it when you're working with an ace USB camera. As the feature sets of these camera models differ, features available on the ace 2 GigE won't be displayed when you're using the ace USB model. If you want to see these unavailable features, select the Show Unavailable Features check box.

Feature tabs created by you can be changed. You can add features, delete features, or change the name of the tab. The Features – All and Features – Basic tabs can't be edited.

To edit a feature tab:

  1. Click the Edit Feature Tabs button.
  2. In the Edit Feature Tabs dialog, select the tab that you want to edit.
  3. Make the desired changes.
  4. Click OK.

Another feature of the Features – All tab is the Common Tasks drop-down list. This is designed to help you quickly complete a variety of common tasks, i.e., changing the resolution or optimizing image quality. By selecting one of the tasks, the relevant features will be highlighted in the feature tree.

On this tab, you can also select whether to automatically poll the camera in regular intervals. Alternatively, you can click the Refresh button (Refresh Icon) to refresh the features list manually.

Image Display Area#

Images and videos taken by the camera are displayed here. There is an image window tab for each camera that is currently open. At the bottom is a status bar that provides information about the image you're capturing or the video you're recording. When positioning your camera, you can display a crosshair and grid as visual aids.

Images can be displayed in full-screen mode by clicking the Full Screen button (Full-screen Button) in the toolbar. To move the full-screen image to a second screen, right-click in the image and then click Screen #2. The image will then move to your second screen.

Feature Documentation Pane#

The Feature Documentation pane displays information about the feature currently selected in the Features pane. The feature descriptions are available in a variety of languages. Pick your language in the Language drop-down list.

Feature Properties Pane#

The Feature Properties pane displays information about the parameter currently selected in the Features pane. Initially, it appears minimized and docked on the right-hand side of the pylon Viewer.

Message Log Pane#

The Message Log pane displays information about actions carried out with the pylon Viewer, e.g., opening and closing a camera or starting a recording. There are different message levels: Information, Warning, and Critical. Initially, it appears minimized and docked on the right-hand side of the pylon Viewer.

Adding Panes#

Via the Window menu, you can select more panes to display. By default, some of them will be docked on the right-hand side of the pylon Viewer, others will be floating.

Rearranging Panes#

All panes in the main window have buttons for closing the pane and for undocking it from the pylon Viewer window. If a pane is undocked, you can move it around freely on your desktop. If you want to dock it again, follow these steps:

  1. Start dragging a pane.
    A positioning aid appears.
    Positioning Aid
  2. With the mouse cursor, point to the location where you want to drop the pane.
    The desired window area will be highlighted in blue.
  3. Drop the pane.

The following animation demonstrates this.

Animation of How to Rearrange Panes

This way you can fully customize the pylon Viewer window and rearrange panes as desired.

Back to top